FTPRush 2.1.4 issues..

Here you can submit your bug reports for FTP Rush.
Posts: 1
Joined: Sat Feb 19, 2011 11:33 pm

FTPRush 2.1.4 issues..

Post by rushthebug »

OS : Server 2008 R2 (64bit)
FTPRush : 2.1.4 (Unicode 26/01/2011)

Issue 1:

If you start uploading a file and you lose network connectivity for a couple of minutes when the network comes back up the download doesn't restart or error it just hangs. (happens in both single transfer mode / multi connection mode)

Issue 2:

When dealing with a hung connection the only way to close it down is to close FTPRush totally (you can't close the connection tab)

Issue 3:

When finished transferring a file and even after closing the connections in a tab, the tab still has the icon of transferring (2 arrows) and you can't close the tab

Issue 4:

When sending a folder full of files to a server, eg /root/folder/<files> and you queue up the folder from /root/ when the transfer is finished FTPRush doesn't always CWD back to /root/ and sometimes stays in /root/folder/
Posts: 4
Joined: Tue Nov 09, 2010 2:38 pm

Re: FTPRush 2.1.4 issues..

Post by phonzie »

2nd that! All true....
Site Admin
Posts: 1935
Joined: Tue Sep 29, 2009 6:09 am

Re: FTPRush 2.1.4 issues..

Post by FTP »

Thanks for your report! All those issues will be noted.

Other people who find some issue with version 2.1.4, please post in this thread, thanks!
Posts: 2
Joined: Thu Feb 24, 2011 9:05 am

Re: FTPRush 2.1.4 issues..

Post by uriah »

Running Windows XP, FTPRush 2.1.4 Unicode...

If you connect to an ftp site, and transfer a file, the transfer connection remains open. When you disconnect the transfer connection continues to remain open, until you close the window, or until it eventually times out.

If you reconnect before it times out, and transfer a file, that file gets put where ever that other connections transfer connection was pointed at.

This happened most noticeably when I was changing the username and password of the same connection, and connecting to different accounts, but on the same FTP.

1: Connect to ftp with an account.
2: Transfer a file.
3: Disconnect.
4: Change the username/password so you're now using a different account, with a different home directory (but maybe both say /).
5: Transfer another file.
6: Watch as the file is transferred into the home directory of your first account, and not the actually connected directory of your second account.

Changing the settings to "disconnect on transfer" meant that it disconnected my transfer threads, and my control thread. This was very annoying.

Had a lot of annoyances with this today. Basically made it unusable for me.
Posts: 9
Joined: Thu Nov 04, 2010 8:36 pm

Re: FTPRush 2.1.4 issues..

Post by bumme666 »

when you fxp several files it locks up 2 files at the time at random ( it say in ftp log "transfering" on 2 files ) and you cant delete the 2nd file.
Posts: 2
Joined: Thu Feb 24, 2011 9:05 am

Re: FTPRush 2.1.4 issues..

Post by uriah »

This might be related to my previous bug that I posted about above, which might be related to the bugs that rushthebug noticed.

However, for completeness sake...

If you click disconnect on an SFTP connection, even if nothing is happening and its a brand new instance, the entire application locks up, and it eventually has to be killed.

When you connect it says...
[1] Retrieving file list...
[1] Listed directory (1 seconds)

When you click disconnect prints the last message again...
[1] Listed directory (1 seconds)

Then locks up.

This seems to only happen with SFTP connections.

Quite annoying!
Posts: 7
Joined: Tue Jan 04, 2011 10:54 am

Re: FTPRush 2.1.4 issues..

Post by BrollyLSSJ »

For me CHMOD is not working. I am connecting to a server using the SSH protocol. I had to use putty to change the CHMOD on the files. Anyone else noticed this problem? Using both installed and portable version on both Windows 7 32 and 64 Bit.

OK, I was able to show and change the CHMOD using FileZilla and WinSCP . Must be a problem with FTP Rush.

As for the lockup someone here is having. I had that also with 2.1.2 and with portable only on Windows 7 64 Bit, but the installed version worked fine there. On my Windows 7 32 version, it was other way. Portable worked fine, but installed version just hang on disconnection.
Posts: 2
Joined: Fri Mar 25, 2011 4:50 pm

Re: FTPRush 2.1.4 issues..

Post by Hemloc »

Using windoze xp, FTP Rush 2.1.4

Found the following issues :

- If you click on the Abort button :
1. Immediately resets the queues columns "Transferred" and "Size"
2. Will stop the current queue item from transferring, but will often simply start the next one in the queue.

- If you abort an upload, and then restart the upload, even if your File Exists Options are set to "Auto Resume" on Target file is smaller, it never does and always does an Auto Rename instead.

- If you double click on the border of a queue column to resize it, it will be resized, but will also now sort by the column name you were resizing.
Posts: 4
Joined: Tue Aug 24, 2004 6:46 pm

Re: FTPRush 2.1.4 issues..

Post by Pion »

When is the next bugfix version due?
Posts: 2
Joined: Wed Jan 05, 2011 3:57 pm

Re: FTPRush 2.1.4 issues..

Post by bytepusher »

"Stop and resume if no data recieved" option does not seem to work. No attempt or reconnect is happening. Possibly related to post #1. In some cases no errors visible in the FTP log, sometimes a [T]"426 - Data connection closed" error appears. Can not remember exact error message, but error code is correct. Happens often, so can c/p if needed.
Multiple time increments have been tested.

When transfering a queue of folders (not empty), sometimes an empty folder will be transfered, and the element is removed from the queue as being tranfered correctly. The data within the folder is just skipped and im left with an empty folder.
When transfering a queue of multiple folders, in some cases 2 dirs are created at the target path (both when down/uploading locally and FXPing) In most cases the files within that 2nd folder is being added to the queue, but in some cases this folder is also being skipped as transfered correctly.

In version 1.1.3, when resuming Windows which was hibernating/on standby, and a transfer was in progress, this transfer would resume when Windows was started again.

These issues has all happened on Win 7 64bit, 2008 and XP
Post Reply