Linux, default file WebLink password 'undefined'

Here you can submit your bug reports.

Linux, default file WebLink password 'undefined'

Postby eordona » Mon Jan 09, 2017 6:44 pm

I just upgraded from v.4.7.3 to v. 4.8.2 (Linux 64-bit version), and now when creating a WebLink the WebLink password by default is: undefined.

If the WebLink is saved and distributed it prompts for a password -- the password is actually: undefined

Isn't this the same bug that was fixed in 4.4.7 ?:

Wing FTP Server v4.4.7 Released: 29/May/2015
Fixed a bug - With Linux version, the WebLink password will be 'undefined' when specify an empty password.


The password should be blank unless we choose to put one in there, this is the way is used to be.

Thanks!
eordona
 
54
 
Fri Aug 24, 2012 5:42 pm

Re: Linux, default file WebLink password 'undefined'

Postby FTP » Tue Jan 10, 2017 3:20 pm

With which web browser? We tested with Firefox, and everything is OK.
FTP
Site Admin
 
1739
 
Tue Sep 29, 2009 6:09 am

Re: Linux, default file WebLink password 'undefined'

Postby eordona » Tue Jan 10, 2017 6:31 pm

This was with the latest version of Chrome (55.0.2883.95) running on OSX. I have also replicated the issue with IE11 running on Windows 10.
eordona
 
54
 
Fri Aug 24, 2012 5:42 pm

Re: Linux, default file WebLink password 'undefined'

Postby eordona » Tue Jan 10, 2017 6:45 pm

This is on CentOS release 6.8, fully patched.
eordona
 
54
 
Fri Aug 24, 2012 5:42 pm

Re: Linux, default file WebLink password 'undefined'

Postby eordona » Wed Jan 18, 2017 4:14 pm

As stated previously, this same issue showed up in the version before 4.4.7, you fixed this in version 4.4.7.

Can you please provide me a fix for this? It's causing a lot of confusion.

Alternatively, is it possible to downgrade WingFTP to a previous version (following the upgrade process but by using an older install file)?

Thanks.
eordona
 
54
 
Fri Aug 24, 2012 5:42 pm

Re: Linux, default file WebLink password 'undefined'

Postby eordona » Wed Jan 18, 2017 7:44 pm

I believe I self-corrected the issue. I was unaware of the new(er) functionality that would copy /wftpserver/webclient/main.html.bak over to /wftpserver/webclient/main.html on startup! As it turns out I had a very old .bak file sitting around that was overwriting the current one.

Once I figured this out, I used the current main.html file and the issue no longer exists.
eordona
 
54
 
Fri Aug 24, 2012 5:42 pm

Re: Linux, default file WebLink password 'undefined'

Postby FTP » Thu Jan 19, 2017 5:33 am

That's great! And thanks for your tips!
FTP
Site Admin
 
1739
 
Tue Sep 29, 2009 6:09 am


Return to Bug Reports

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest

cron