Page 1 of 1

Can't use Jupload and Jdownload in version 4.3.8

PostPosted: Fri Jul 04, 2014 3:37 am
by FTP
If you can't use Jupload and Jdownload in version 4.3.8, you can modify the file "webclient/loginok.html", replace the lines 23 - 35 into:

Code: Select all
   if _COOKIE["UID"] ~= nil then
      _SESSION_ID = _COOKIE["UID"]
      local retval = SessionModule.load(_SESSION_ID)
      if retval == false then
         _SESSION_ID = SessionModule.new()
         _SETCOOKIE = _SETCOOKIE.."Set-Cookie: UID=".._SESSION_ID.."\r\n"
         rawset(_COOKIE,"UID",_SESSION_ID)
      end
   else
      _SESSION_ID = SessionModule.new()
      _SETCOOKIE = _SETCOOKIE.."Set-Cookie: UID=".._SESSION_ID.."\r\n"
      rawset(_COOKIE,"UID",_SESSION_ID)
   end

Re: Can't use Jupload and Jdownload in version 4.3.8

PostPosted: Thu Mar 01, 2018 9:04 pm
by william
Would I use the same code replacement for the Secure Edition?

Thanks in advance for any input.

-Will

Re: Can't use Jupload and Jdownload in version 4.3.8

PostPosted: Sat Mar 03, 2018 1:42 pm
by FTP
Yes, this code replacement is for the old version which <= 4.3.8.
And another thing is, most web browser doesn't support Java applet any more, so you can't use those web client plugins in the recent web browser.